package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:\w+|\w+\.\w+)+$`)
var str = `com
com.package
com.package.test
.
com.invalid.
com.invalid..ff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}