const regex = /^(?:\w+|\w+\.\w+)+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\w+|\\w+\\.\\w+)+$', 'gmi')
const str = `com
com.package
com.package.test
.
com.invalid.
com.invalid..ff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}