$re = '/^(?:\w+|\w+\.\w+)+$/mi';
$str = 'com
com.package
com.package.test
.
com.invalid.
com.invalid..ff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);