import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(BBF10K)(.*)\\.(gb|gbk)";
final String string = "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2a_keoni_pip501_transfe.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2b_orit_oyc.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/3a_ecoli_kanr.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/4_ecoori_cole1pmb1pbr32.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/5_bsubori_pbs72_repa.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/6_cata9.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/7_bsub_laci_laco_promo.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000207.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000210.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000211.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000217.gb\n"
+ "friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000227.gb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}