const regex = new RegExp('(BBF10K)(.*)\\.(gb|gbk)', 'gm')
const str = `friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2a_keoni_pip501_transfe.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2b_orit_oyc.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/3a_ecoli_kanr.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/4_ecoori_cole1pmb1pbr32.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/5_bsubori_pbs72_repa.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/6_cata9.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/7_bsub_laci_laco_promo.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000207.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000210.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000211.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000217.gb
friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000227.gb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}