import re
regex = re.compile(r"(BBF10K)(.*)\.(gb|gbk)", flags=re.MULTILINE)
test_str = ("friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2a_keoni_pip501_transfe.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/2b_orit_oyc.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/3a_ecoli_kanr.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/4_ecoori_cole1pmb1pbr32.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/5_bsubori_pbs72_repa.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/6_cata9.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openBacillus/7_bsub_laci_laco_promo.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000207.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000210.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000211.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000217.gb\n"
"friendzymes-cookbook/blob/main/data/dna-annotate/input/openYeast/BBF10K_000227.gb")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")