import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<span[^>]*>\\K.*?.(?=<\\/span>)";
final String string = "<span class=\"st\">My Paragraph - you can download free <b>drivers</b> for audio, video, chipset, Wi\n"
+ "Fi or USB, or a <b>driver</b> installation pack for <b>notebook</b>/(for ...</span><br></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}