re = /(?s)<span[^>]*>\K.*?.(?=<\/span>)/
str = '<span class="st">My Paragraph - you can download free <b>drivers</b> for audio, video, chipset, Wi
Fi or USB, or a <b>driver</b> installation pack for <b>notebook</b>/(for ...</span><br></div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end