const regex = /(?s)<span[^>]*>\K.*?.(?=<\/span>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<span[^>]*>\\K.*?.(?=<\\\/span>)', '')
const str = `<span class="st">My Paragraph - you can download free <b>drivers</b> for audio, video, chipset, Wi
Fi or USB, or a <b>driver</b> installation pack for <b>notebook</b>/(for ...</span><br></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}