using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<?[^ph=])";
string input = @"<?
some function();
?>
<h1>This is some <?=poorly?> written php</h1>
<?php
echo 'along with proper code';
?>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}