re = /(<?[^ph=])/
str = '<?
some function();
?>
<h1>This is some <?=poorly?> written php</h1>
<?php
echo \'along with proper code\';
?>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end