const regex = /(<?[^ph=])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<?[^ph=])', '')
const str = `<?
some function();
?>
<h1>This is some <?=poorly?> written php</h1>
<?php
echo 'along with proper code';
?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}