$re = '/(<?[^ph=])/';
$str = '<?
some function();
?>
<h1>This is some <?=poorly?> written php</h1>
<?php
echo \'along with proper code\';
?>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);