package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)) (?:[ \t]*[*+/-][ \t]* [+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)))*`)
var str = `( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}