import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]?(?:\\d+(?:\\.\\d+)?|\\([ \\t]*(?R)[ \\t]*\\)) (?:[ \\t]*[*+/-][ \\t]* [+-]?(?:\\d+(?:\\.\\d+)?|\\([ \\t]*(?R)[ \\t]*\\)))*";
final String string = "( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) ";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}