#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w*(?!SearchResponse\.java)"
Local $sString = "src/main/java/com/truecar/mobile/android/mdk/model/used/search/Model.java" & @CRLF & _
"src/main/java/com/truecar/mobile/android/mdk/model/used/search/RefineParameters.java" & @CRLF & _
"src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchRequest.java" & @CRLF & _
"src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchResponse.java"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")