using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*(?!SearchResponse\.java)";
string input = @"src/main/java/com/truecar/mobile/android/mdk/model/used/search/Model.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/RefineParameters.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchRequest.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchResponse.java";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}