const regex = /\w*(?!SearchResponse\.java)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w*(?!SearchResponse\\.java)', 'g')
const str = `src/main/java/com/truecar/mobile/android/mdk/model/used/search/Model.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/RefineParameters.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchRequest.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchResponse.java`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}