re = /\w*(?!SearchResponse\.java)/
str = 'src/main/java/com/truecar/mobile/android/mdk/model/used/search/Model.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/RefineParameters.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchRequest.java
src/main/java/com/truecar/mobile/android/mdk/model/used/search/SearchResponse.java'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end