#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-\d+x\d+(\.[^.\s]+)$"
Local $sString = "http://az648995.vo.msecnd.net/win/2015/11/Halo-1024x551.jpg" & @CRLF & _
"http://az648995.vo.msecnd.net/win/2015/11/slot-Drake-08-2000x1000-1024x512.jpg"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)