const regex = /-\d+x\d+(\.[^.\s]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d+x\\d+(\\.[^.\\s]+)$', 'gm')
const str = `http://az648995.vo.msecnd.net/win/2015/11/Halo-1024x551.jpg
http://az648995.vo.msecnd.net/win/2015/11/slot-Drake-08-2000x1000-1024x512.jpg`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);