use strict;
my $str = 'http://az648995.vo.msecnd.net/win/2015/11/Halo-1024x551.jpg
http://az648995.vo.msecnd.net/win/2015/11/slot-Drake-08-2000x1000-1024x512.jpg';
my $regex = qr/-\d+x\d+(\.[^.\s]+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";