using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/es(?:\/[\w-]+){3}$";
string input = @"/es/whathever1/whathever2/whatever3
/es/whathever1/whathever2
/es/whathever1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}