$re = '/^\/es(?:\/[\w-]+){3}$/m';
$str = '/es/whathever1/whathever2/whatever3
/es/whathever1/whathever2
/es/whathever1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);