package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/es(?:\/[\w-]+){3}$`)
var str = `/es/whathever1/whathever2/whatever3
/es/whathever1/whathever2
/es/whathever1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}