re = /^\/es(?:\/[\w-]+){3}$/m
str = '/es/whathever1/whathever2/whatever3
/es/whathever1/whathever2
/es/whathever1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end