#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(a(?1)?b)$"
Local $sString = "abc" & @CRLF & _
"aabbcc" & @CRLF & _
"aaabbbccc" & @CRLF & _
"" & @CRLF & _
"abbc" & @CRLF & _
"aabbc" & @CRLF & _
"aabbbccc" & @CRLF & _
"" & @CRLF & _
"ab" & @CRLF & _
"aabb" & @CRLF & _
"aaabbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")