package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(a(?1)?b)$`)
var str = `abc
aabbcc
aaabbbccc
abbc
aabbc
aabbbccc
ab
aabb
aaabbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}