import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(a(?1)?b)$";
final String string = "abc\n"
+ "aabbcc\n"
+ "aaabbbccc\n\n"
+ "abbc\n"
+ "aabbc\n"
+ "aabbbccc\n\n"
+ "ab\n"
+ "aabb\n"
+ "aaabbb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}