re = /^(a(?1)?b)$/mx
str = 'abc
aabbcc
aaabbbccc
abbc
aabbc
aabbbccc
ab
aabb
aaabbb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end