#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\w*(?:f+(?:\W*[uoc]*)*k+|s+(?:\W*[hia]*)*t+|a[$s]|arse)\w*)\b"
Local $sString = "fuck" & @CRLF & _
"" & @CRLF & _
"f.cuk" & @CRLF & _
"" & @CRLF & _
"fck" & @CRLF & _
"" & @CRLF & _
"theres this fucking fuck you f.uck fkuck fuckfinhg" & @CRLF & _
"fuck fck" & @CRLF & _
"fock" & @CRLF & _
"fucccckkkkkkkkkkkkkkingggggg " & @CRLF & _
"" & @CRLF & _
" sjns skndnsiofns" & @CRLF & _
"" & @CRLF & _
"f" & @CRLF & _
"u" & @CRLF & _
"k" & @CRLF & _
"" & @CRLF & _
"u" & @CRLF & _
"" & @CRLF & _
"fffff.uuuuuu.kkkkkk" & @CRLF & _
"" & @CRLF & _
"fucked shit idiot asshole" & @CRLF & _
"shit fuck" & @CRLF & _
"" & @CRLF & _
"shat shitty" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")