const regex = /\b(\w*(?:f+(?:\W*[uoc]*)*k+|s+(?:\W*[hia]*)*t+|a[$s]|arse)\w*)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w*(?:f+(?:\\W*[uoc]*)*k+|s+(?:\\W*[hia]*)*t+|a[$s]|arse)\\w*)\\b', 'g')
const str = `fuck
f.cuk
fck
theres this fucking fuck you f.uck fkuck fuckfinhg
fuck fck
fock
fucccckkkkkkkkkkkkkkingggggg
sjns skndnsiofns
f
u
k
u
fffff.uuuuuu.kkkkkk
fucked shit idiot asshole
shit fuck
shat shitty
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}