import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w*(?:f+(?:\\W*[uoc]*)*k+|s+(?:\\W*[hia]*)*t+|a[$s]|arse)\\w*)\\b";
final String string = "fuck\n\n"
+ "f.cuk\n\n"
+ "fck\n\n"
+ "theres this fucking fuck you f.uck fkuck fuckfinhg\n"
+ "fuck fck\n"
+ "fock\n"
+ "fucccckkkkkkkkkkkkkkingggggg \n\n"
+ " sjns skndnsiofns\n\n"
+ "f\n"
+ "u\n"
+ "k\n\n"
+ "u\n\n"
+ "fffff.uuuuuu.kkkkkk\n\n"
+ "fucked shit idiot asshole\n"
+ "shit fuck\n\n"
+ "shat shitty\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}