$re = '/\b(\w*(?:f+(?:\W*[uoc]*)*k+|s+(?:\W*[hia]*)*t+|a[$s]|arse)\w*)\b/';
$str = 'fuck
f.cuk
fck
theres this fucking fuck you f.uck fkuck fuckfinhg
fuck fck
fock
fucccckkkkkkkkkkkkkkingggggg
sjns skndnsiofns
f
u
k
u
fffff.uuuuuu.kkkkkk
fucked shit idiot asshole
shit fuck
shat shitty
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);