package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\-{3,}`)
var str = `--------------------------------
hello
--------------------------------
world
--------------------------------
!`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}