$re = '/\-{3,}/';
$str = '--------------------------------
hello
--------------------------------
world
--------------------------------
!';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;