use strict;
my $str = '--------------------------------
hello
--------------------------------
world
--------------------------------
!';
my $regex = qr/\-{3,}/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";