const regex = /\-{3,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\-{3,}', 'g')
const str = `--------------------------------
hello
--------------------------------
world
--------------------------------
!`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);