using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?P<a>\d+\.\d{2})(?P<supplierPrice>[^\s])\s*$";
string input = @" 23.0003NOV14DIX ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}