$re = '/^\s*(?P<a>\d+\.\d{2})(?P<supplierPrice>[^\s])\s*$/';
$str = ' 23.0003NOV14DIX ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);