package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*(?P<a>\d+\.\d{2})(?P<supplierPrice>[^\s])\s*$`)
var str = ` 23.0003NOV14DIX `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}