re = /^\s*(?P<a>\d+\.\d{2})(?P<supplierPrice>[^\s])\s*$/
str = ' 23.0003NOV14DIX '
# Print the match result
str.match(re) do |match|
puts match.to_s
end