import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:src=)(\".*?\")";
final String string = "Russia's National Settlement Depository discusses why it believes the biggest blockchain opportunities have yet to be uncovered.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/rvoQUj-KDaw\" width=\"1\" />|One of the co-founder of digital currency startup Stellar announced their resignation today.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/xRzN7syt-v0\" width=\"1\" />|The editorial board for Bloomberg News has called for a permissive regulatory environment for blockchain development.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/ooQYB2iDxP8\" width=\"1\" />";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}