# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:src=)(\".*?\")"
test_str = "Russia's National Settlement Depository discusses why it believes the biggest blockchain opportunities have yet to be uncovered.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/rvoQUj-KDaw\" width=\"1\" />|One of the co-founder of digital currency startup Stellar announced their resignation today.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/xRzN7syt-v0\" width=\"1\" />|The editorial board for Bloomberg News has called for a permissive regulatory environment for blockchain development.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/ooQYB2iDxP8\" width=\"1\" />"
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.