import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(SWEx-elmPCI-A-02\\.lssh\\.com)\\s+(.*?)\\s{2,}(\\d+)\\s+(.*?)\\s{2,}([^\\s]+)\\s+(.*?)$";
final String string = "Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge\n"
+ " S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,\n"
+ " D - Remote, C - CVTA, M - Two-port Mac Relay\n\n"
+ "Device ID Local Intrfce Holdtme Capability Platform Port ID\n"
+ "SWEx-elmPCI-A-02.lssh.com\n"
+ " Gig 2/0/1 137 R S I WS-C3750X Gig 1/0/1\n"
+ "SWEx-elmPCI-A-02.lssh.com\n"
+ " Gig 2/0/1 138 R S I WS-C3750X Gig 1/0/1\n\n"
+ "SWEa-elmPCI-02 Gig 1/0/4 169 T AIR-LAP12 Gig 0\n"
+ "SWEa-elmPCI-01 Gig 1/0/9 170 T AIR-LAP11 Gig 0";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}