const regex = new RegExp('^(SWEx-elmPCI-A-02\\.lssh\\.com)\\s+(.*?)\\s{2,}(\\d+)\\s+(.*?)\\s{2,}([^\\s]+)\\s+(.*?)$', 'gsm')
const str = `Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID Local Intrfce Holdtme Capability Platform Port ID
SWEx-elmPCI-A-02.lssh.com
Gig 2/0/1 137 R S I WS-C3750X Gig 1/0/1
SWEx-elmPCI-A-02.lssh.com
Gig 2/0/1 138 R S I WS-C3750X Gig 1/0/1
SWEa-elmPCI-02 Gig 1/0/4 169 T AIR-LAP12 Gig 0
SWEa-elmPCI-01 Gig 1/0/9 170 T AIR-LAP11 Gig 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}