// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)^(SWEx-elmPCI-A-02\.lssh\.com)\s+(.*?)\s{2,}(\d+)\s+(.*?)\s{2,}([^\s]+)\s+(.*?)$").unwrap();
let string = "Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID Local Intrfce Holdtme Capability Platform Port ID
SWEx-elmPCI-A-02.lssh.com
Gig 2/0/1 137 R S I WS-C3750X Gig 1/0/1
SWEx-elmPCI-A-02.lssh.com
Gig 2/0/1 138 R S I WS-C3750X Gig 1/0/1
SWEa-elmPCI-02 Gig 1/0/4 169 T AIR-LAP12 Gig 0
SWEa-elmPCI-01 Gig 1/0/9 170 T AIR-LAP11 Gig 0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}