use strict;
my $str = 'Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID Local Intrfce Holdtme Capability Platform Port ID
SWEx-elmPCI-A-02.lssh.com
Gig 2/0/1 137 R S I WS-C3750X Gig 1/0/1
SWEx-elmPCI-A-02.lssh.com
Gig 2/0/1 138 R S I WS-C3750X Gig 1/0/1
SWEa-elmPCI-02 Gig 1/0/4 169 T AIR-LAP12 Gig 0
SWEa-elmPCI-01 Gig 1/0/9 170 T AIR-LAP11 Gig 0';
my $regex = qr/^(SWEx-elmPCI-A-02\.lssh\.com)\s+(.*?)\s{2,}(\d+)\s+(.*?)\s{2,}([^\s]+)\s+(.*?)$/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}