using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"handshake\/+reply\/+(?<deploy_client_name>[^\/]+)\/+(?<deploy_client>\S+)";
string input = @"tenantService/handshake/reply/ax/mx
tenantService/handshake/reply/Lx/wx1
tenantService/handshake/reply/Dx/wx2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}