package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`handshake\/+reply\/+(?<deploy_client_name>[^\/]+)\/+(?<deploy_client>\S+)`)
var str = `tenantService/handshake/reply/ax/mx
tenantService/handshake/reply/Lx/wx1
tenantService/handshake/reply/Dx/wx2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}